ijava学习网> 知识分享> Linux> 华为下的VLAN

华为下的VLAN

时间: 2019-02-11 16:02:09 标签华为下 , VLAN

VLAN配置思路:
1、创建VLAN
2、配置端口模式
-dynamic
-access
-trunk
3、将端口放入VLAN

注意:
所有的交换机上的 VLAN 数据库得是相同的。

华为下的 VLAN
1、创建VLAN
vlan 12
quit

2、配置链路类型(也可以称之为端口模式)
interface gi0/0/1
port link-type access

3、将端口放入指定的 VLAN
interface gi0/0/1
port default vlan 12
4、验证 VLAN 配置信息
display vlan

配置 Trunk 链路:
interface gi0/0/24
port link-type trunk
port trunk allow-pass vlan all

Hybrid 端口
-应用场景
需要同时与多个 VLAN 的终端进行通信的端口,才被配置成
hybrid 模式。一般为服务器端口或者连接网络设备的端口。

 -与 trunk 类似
      # 相同点:都可以在一个端口传输多个VLAN的数据;
      # 不同点:trunk 上的所有数据都必须得有标签;
                hybrid 上的数据,可以没有标签(是可以人为控制的)
 -原理
    1、接收数据时,如果有标签,则按照已有的标签进行处理;
                   如果无标签,则按照该端口上的 PVID 为数据
                   分配一个标签。
    2、发送数据时,查看 display vlan 中的端口与 VLAN的映射关系
                   在该映射关系中,需要关注的是端口在该VLAN中
                   是否有“UT”或者“TG”的标记。                       

interface gi0/0/1
port link-type hybrid -->默认情况下,链路类型就是 hybrid
port hybrid pvid vlan 30 --> 更改端口的 PVID ,默认是1;
port hybrid untagged vlan 30 --->表示将 VLAN 30 的数据在该
端口上发送出去时,不需要携带
标签。
port hybrid tagged vlan 10 --->表示将 VLAN 10 的数据在该端口
上发送出去时,必须携带标签。


SW1:
interface gi0/0/1 ----->连接的是 PC-1;
port link-type hybrid
port hybrid untagged vlan 10 20
interface gi0/0/24 ----->连接的是 SW2,配置为 Trunk ;
port link-type trunk
port trunk allow-pass vlan all
SW2:
interface gi0/0/1 ------>连接的是 PC-3;
port link-type hybrid
port hybrid untagged vlan 10 20
interface gi0/0/2 ------>连接的是 PC-3;
port link-type hybrid
port hybrid untagged vlan 10 20
interface gi0/0/24 ----->连接的是 SW1,配置为 Trunk ;
port link-type trunk
port trunk allow-pass vlan all

数据流描述:本质是通过 VLAN 1 互通的;
192.168.10.3 ----> SW2 ---> 192.168.10.4
1、10.3发送的数据是没有标签的;
2、SW2的端口 gi0/0/1收到以后,基于端口的 pvid(1),打上vlan1的标签
3、SW2查看 VLAN 1 的成员关系表,确定成员端口 - display vlan
4、出端口 gi0/0/2 属于 vlan 1,并且是不携带标签的。所以与PC-4互通

数据流描述:本质是通过 VLAN X 互通的;
192.168.10.3 ----> SW2 --(trunk)---> SW1 ---> 192.168.10.1


GVRP:通用 VLAN 注册协议(generic vlan registribution protocol)
-类似于 Cisco 的 VTP ;
-在交换机之间动态的传递 VLAN 信息;
-通过 GVRP 方式学习到的 VLAN ,称之为“动态 VLAN ”;
-“动态VLAN”不能直接使用,必须在本地手动创建一下才可以;

配置过程:
0、确保交换机之间的 Trunk 是完好的
1、全局开启 GVRP
[sw1]gvrp
2、端口开启 GVRP
[sw1]interface gi0/0/24
[sw1-gi0/0/24]#gvrp
3、配置端口的 GVRP 的模式(可选)
[sw1]interface gi0/0/24
[sw1-gi0/0/24]gvrp registribution ?
normal -正常,可以接收和发送 GVRP 的包;(默认)
fixed - 可以接收,但是不可以发;
forbidden - 拒绝,不可以收,也不可以发;
4、验证 GVRP 和 VLAN
[sw1]display gvrp status / statistic //查看GVRP的状态和
统计信息
[sw1]display vlan summary //查看本地的动态VLAN和
静态VLAN的汇总信息

                                                                                                        李军
                                                                                                                                                                                        Tel:15135361516
                                                                                                                                                                                                qq:344728662
                                                                                                                                                                        @:501xiaofeng@163.cjom

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com