ijava学习网> 知识分享> Linux> OSPF路由表

OSPF路由表

时间: 2019-02-11 16:02:09 标签OSPF , 路由表

OSPF邻居表: adjancy - show ip ospf neighbor
OSPF数据库: LSDB - show ip ospf database
OSPF路由表: RIB(routing information base)- show ip route ospf

type prefix/mask [ad/metric] via next-hop , out-interface
c : 0 , 0
s : 1 , 0
r : 120 , hop
d / d ex :90,170,5 , (K1/K2/K3/K4/K5,带宽、可靠性、延迟、负载、MTU)
o / ia / e1 / e2 / n1 / n2 : 110 , cost

OSPF路由表:
-路由过滤;
distribute-list(只能是做入向的“路由”过滤)
acl/prefix-list

  • 标准ACL
    只能看前缀;
  • 扩展ACL
    同时看前缀和掩码,但是只能在BGP中使用;
  • 前缀列表
    同时看前缀和掩码,在所有的IGP中都能用;
    配置:
    ip prefix-list {name} deny/permit
    {想匹配的多个路由条目的公共部分}
    {子网掩码的长度范围}
    192.168.1.0/24 -> 4
    192.168.0.0/25 -> 8
    192.168.2.0/26 -> 16
    192.168.3.0/27 -> 32

            192.168.0000 0000.0000 0000 
            192.168.0000 0001.0                 
            192.168.0000 0010.0                            
            192.168.0000 0011.0 
    
            #确定公共前缀时:
                   关注的是多个路由条目从左至右的连续的不变化的位;
                   不变的位,直接写下来;变化的位,通过0表示;
                所以-192.168.0.0/22
            #确定多个路由条目的子网掩码的长度范围
                     大于等于24,小于等于24  
                     大于等于24,小于等于27                       
    
            所以,最终的 prefix-list :

ip prefix-list ABC deny 192.168.0.0/22 ge 24 le 27

ip prefix-list ABC deny 192.168.0.0/24
ip prefix-list ABC deny 192.168.1.0/24
ip prefix-list ABC deny 192.168.2.0/24
ip prefix-list ABC deny 192.168.3.0/24

注意:
在前缀列表中表示子网掩码长度时,
如果不写ge,则表示掩码与前面的公共长度相同;
如果不写le,则表示掩码小于等于32(前提是得写ge)
如果都不写,则表示ge和le,都等于前面的公共长度;
在前缀列表中,同样在最后存在一个隐含的拒绝所有;
在prefix-list表示“允许所有”:
permit 0.0.0.0/0 le 32
在prefix-list表示“允许默认路由”:
premit 0.0.0.0/0

LSA的过滤:
   -3类LSA
      在产生这个LSA的 ABR 进行实施;
        router ospf 1
          area 0 filter-list prefix AAA in 
            or 
          area 12  filter-list prefix AAA out 
        !
        ip prefix-list AAA deny 10.10.10.10/32
        ip prefix-list AAA permit 0.0.0.0/0 le 32 
        !
        show ip ospf
    -5类LSA
       在产生这个LSA的 ASBR 上才可以实现过滤,只能做出向过滤
       R1:
         ip route 100.1.1.0 255.255.255.0 null 0 
         ip route 200.1.1.0 255.255.255.0 null 0 
         !
         router ospf 1
           redistribute static subnet
          !
         ip prefix-list  clicli deny 100.1.1.0/24
         ip prefix-list  clicli permit 0.0.0.0/0 le 32 
         !
         router ospf 1
           distribute-list prefix clicli out     

-路由属性修改
     AD
       router ospf 1
          distance {value} ->将该设备上的所有的OSPF路由的AD
                             都更改为 value ; 
          distance {value} [update-source] [wildcardbits] [acl]
                    ->修改特定更新源发送过来的特定ACL匹配的路由
                      的管理距离为 value ;
        show ip protocols 
        show ip route ospf 

              ip access-list standard 66
                     permit 66.1.1.1

     Metric(在OSPF中,称之为 cost - 开销)
         无论是什么协议的路由,在计算Metric的时候,仅仅关心
         的是路由沿传递方向上的所有入端口的;
         OSPF的路由的 Metric 计算方法为:
             沿路由传递方向,所有入端口的 cost 的累加和。
        # 每个端口上的 OSPF  cost 计算方法如下:
              Cost = 100000000/bw
                   bw表示的是接口带宽,代为是 bit ; 
                   所得除数小于1的,都按照整数1来计算。
            上面的 10的8次方,我们称之为计算路由时的“参考带宽”。
            可以通过命令进行你更改(当网络中的路由器之间的互联链路带宽都大于100M的时候)
               router ospf 1
                  auto-cost reference-bandwidth 1000(单位是Mbit;)
                  如果进行该参数的修改,必须在全网的每一个路由器
                  都得进行修改,否则会出现路由次优路径。
        配置命令:
              interface fas0/0 
                 ip ospf cost {value} //更改某一个端口的cost;
        验证命令: 
               show ip ospf interface fas0/0 

-汇总
  自动汇总:NO
  手动汇总:YES 
     -对象
         3类LSA和5类LSA
     -配置命令:
         3类LSA汇总
            在产生被汇总的3类LSA的ABR上进行配置
            配置完成以后,仅仅发送汇总之后的3类LSA,不发送明细LSA
            并且会在本地形成一个针对汇总路由的Null0路由,
            目的是为了实现防止数据转发环路的产生。
            router ospf 1
              area 12 range 10.10.0.0 255.255.0.0 [not-advertise]
                  默认动作是将汇总之后的LSA发送出去的;
                  也可以不发出去,从而实现 LSA过滤的效果。
            show ip ospf --> 查看上面的配置命令显示;
            show ip ospf database -->没有明细,仅有汇总之后的LSA                
         5类LSA汇总
            在产生5类LSA的 ASBR 上面操作:
              router ospf 1
                summary-address 10.10.0.0 255.255.0.0 

LSA,link state advertise ,链路状态通告;
一个链路需要通过1个或者是多个 LSA 来表示。

网络类型
MA
NBMA
P2P
P2MP
P2MP-NB
LSA类型:
1类 - 任何一个OSPF路由器,都会在任何一个区域产生一个;
2类 - DR可以产生,表示的是 DR 可以覆盖的路由器;
(每一个网段-如果是MA类型,就得需要选举一个DR)
3类 - 只有 ABR 可以产生,为了在不同的区域之间传递路由;
4类 - 由与 ASBR在同一个区域的ABR产生,表示的是 ASBR的RID;
5类 - 没有任何区域概念,传输过程中,没有任何改变;

区域的不规则连接:
多个非0区域连接在一起,相应的解决方案:
1、static
2、动态
OSPF
内部:OIA
ABR
让路由器连接区域0
建立一个区域0的邻居就可以;
virtual-link
外部: 5
ASBR
在特定的路由器上进行重分发
得考虑构建2个或者多个OSPF进程,
然后他们之间互相进行重分发;

R1;
interface loopback 0
ip ospf network point-to-point

R3:
acl
ip access-list standard 1
deny 10.10.1.0
permit any
router rip
distribute-list 1 in fas0/1

prefix-list 
   ip prefix-list ABC deny  10.10.1.0/24
   ip prefix-list ABC permit  0.0.0.0/0 le 32 
   router ospf 1
      distribute-list prefix ABC in fas0/1     

10.10.1.X
/24 --> 10.10.1.0/24
/25 --> 10.10.1.0000 0000/25 - > 10.10.1.0/25
10.10.1.1000 0000/25 - > 10.10.1.128/25

匹配

                                                                                                          李军
                                                                                                                                                                                        Tel:15135361516
                                                                                                                                                                                                qq:344728662
                                                                                                                                                                        @:501xiaofeng@163.cjom

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com