ijava学习网> 知识分享> Linux> 静态路由和默认路由

静态路由和默认路由

时间: 2019-02-11 16:02:09 标签静态路由 , 默认路由

路由
-动态
RIP/IGRP/EIGRP
ISIS/OSPF
BGP
工作原理
报文
-request
-respone
工作表
-数据库
-路由表
路由控制
-认识路由
type prefix/mask [ad/metric] via next-hop , interface
-匹配路由
ACL
-标准ACL
只能匹配前缀
-扩展ACL
可以同时匹配前缀和掩码
-控制路由
过滤
-distribute-list
-distance
-offset-list
-增强路由稳定性
汇总
-自动汇总
-手动汇总
-默认路由

默认路由
-静态默认路由
ip route 0.0.0.0 0.0.0.0 192.168.12.2(ISP)
-动态默认路由

EIGRP: 
    该协议是思科私有协议,属于 OSI 模型 第3层,协议号为
    88。报文发送方式是组播,组播地址为 224.0.0.10; 
    使用的是自己的私有算法 - DUAL,确保网络绝对无环。
  -工作原理
        1、邻居表 - show ip eigrp neighbor 
        2、数据库 - show ip eigrp topology
        3、路由表 - show ip route eigrp 
  -报文类型
        1、hello : 建立 EIGRP 邻居;
        2、update:同步路由更新;
        3、Ack:实现确认作用,确保报文可靠传输;
        4、query:查询报文,用于查询/请求自己丢失的路由信息;
        5、reply:回应报文,用于对 query 报文的回应。           
  -建立邻居影响因素
        1、最小范围内双向ping通;
        2、可以正常发送 eigrp 的包;
              #确保端口启用了 EIGRP 进程(network成功)
        3、可以正常接收 eigrp 的包;
              #确保端口启用了 EIGRP 进程
              #确保端口上没有3层ACL干掉 EIGRP 
        4、可以正常比较 eigrp 的包;
              # as 号必须相同;
              # K 值必须相同;
              # 认证必须成功(MD5);

   -常用命令:
        show ip protocols 
         # 修改K值:
               router eigrp 100
                   metric weight 0  1  0 1 0  0 
         # 修改计时器(默认hello是5s,hold是15s)
                -高速链路而言,hello 5s , hold 15s ; 
                -低速链路而言,hello 40s, hold 120s ; 
                 大于 1.544Mbps 的链路,称之为高速;
               interface fas0/0 
                    ip hold-time eigrp 100   21
               interface  fas0/0 
                    ip hello-interval eigrp 100 7

注意:


LS
支持网络的层次化设计
-区域
骨干 : 0区域,就是骨干区域
非骨干:不是区域0的,都叫做非骨干区域
所有的非0区域,必须直接连接0区域;
非0区域之间,不可以直接进行通信的;

配置命令:
router ospf 1
netowrk x.x.x.x y.y.y.y area {id}
router-id n.n.n.n

OSPF邻接建立影响因素:
1、确保最小范围内双向ping通;
2、能够正常发送OSPF报文;
#确保链路正常宣告;
3、能够正常接收OSPF报文;
#确保链路正常宣告;
#确保ACL放行 OSPF 流量;
4、开始比较OSPF报文参数:
1、RID不能相同;
router ospf 1
router-id x.x.x.x
clear ip ospf process
2、区域ID必须相同;
3、认证必须成功(认证类型必须相同,并且密码必须相同)
4、子网掩码必须相同(特殊情况下)
5、hello时间必须相同;
interface fas0/0
ip ospf hello-interval {value}
6、dead时间必须相同;
interface fas0/0
ip ospf dead-interval {value}
7、特殊标记位必须相同;
8、优先级必须不能全为0(特殊情况下)
interface fas0/0
ip ospf priority {value}
9、3层MTU必须相同,否则会卡在 Exstart 状态;
interface fas0/0
ip mtu 1499

注意:
MTU - 最大传输单元,max transmit unit

调试命令:
debug ip ospf hello -->比较 hello 中的参数时,使用该命令;
debug ip ospf adj --->比较 OSPF 头部中参数时,使用该命令;


华为配置 OSPF 的命令:
[R1]ospf 10 router-id 1.1.1.1
[R1-ospf-10]area 12
[R1-ospf-10-area-0.0.0.12]network 192.168.12.0 0.0.0.255

验证命令:
display ospf 10 brief // 类似于 show ip protocols
display ospf 10 peer [brief] // 类似于 show ip ospf neighbor
display ospf 10 lsdb //类似于show ip ospf database

                                                                                                                 李军
                                                                                                                                                                                                     Tel:15135361516
                                                                                                                                                                                                             qq:344728662
                                                                                                                                                                                     @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com