ijava学习网> 知识分享> Linux> 网关冗余协议

网关冗余协议

时间: 2019-02-11 17:02:08 标签网管 , 冗余 , 协议

网关冗余协议

HSRP - 思科私有
VRRP - 公有标准 

经过前面内容的学习,我们已经完全掌握了一个网段中的通信过程,

熟悉了交换机的工作原理,以及在2层设备上如何区分不同的广播域 - VLAN
并且不同的 VLAN 之间的简单通信,也有所了解。
不同VLAN之间通信,我们称之为路由,得用到网关的概念。

为了提高网络的稳定性,我们可以在网络中部署多个网关。

当终端主机上网的时候,可以选择其中的任何一个进行外网的访问。

如果一个网关挂掉了,可以选择另外一个。

两个网关之间可以形成备份。

并且,当两个网关设备都完好的时候,两个设备之间,还可以进行流量
的负载均衡。

 但是,存在的问题是,我们需要在一个终端主机上配置两个网关IP地址

但是,这种方式是无法实现的,因为每个终端设备只可以配置一个网关。
如此一来,每次网关设备坏掉的时候,我们得通知终端工作人员,自己更换
网关IP地址,这种方式对于用户而言,感受是非常不好的。

所以,我们可以使用虚拟化技术,让两个网关设备,虚拟成一个网关。

然后,我们在每个终端设备上配置网关IP地址的时候,仅仅配置这一个
虚拟网关的IP地址,就可以了。

以后,终端在进行访问外网的时候,就可以直接向虚拟网关IP地址发包

就可以了。

可以实现网关虚拟化的协议,也称之为“网关冗余“协议,分为
私有协议 - HSRP (hot-standby routing protocol )
公有协议 - VRRP (virtual route redundancy protocol )

HSRP
-定义 双机热备协议
在多个网关之间运行该协议,可以虚拟出一个“虚拟网关”,
该虚拟网关有自己的虚拟IP地址和虚拟MAC地址。
-设备角色
active : 参与到 hsrp 协议中的路由器,有一个 活动设备 ,
该设备才是真正用来转发上网数据的设备;
standby: 参与到 hsrp 协议中的路由器,有一个 备份设备,
当 活动设备 挂掉以后,该设备就升级为活动设备,
用于实现数据的转发
-选举原则:
比较参与 HSRP 协议的多个网关的优先级以及IP地址,
首先比较优先级,默认是100,越大越好;
如果优先级相同,则比较IP地址,越大越好;
-配置命令:
-HSRP
R1:
interface gi0/0/0
no shutdown
ip address 192.168.10.201 255.255.255.0 // 配置网关1的IP地址;
standby 10 ip 192.168.10.254 // 配置 vlan 10 中的虚拟网关的IP地址;
standby 10 priority 105 // 配置 vlan10 中的网关1的 HSRP 优先级
standby 10 preempt // 开启 网关1 在 HSRP 组10 中的抢占功能;
R2:
interface gi0/0/0
no shutdown
ip address 192.168.10.202 255.255.255.0
standby 10 ip 192.168.10.254
standby 10 preempt //(可选)

-多组的HSRP
      我们可以为 HSRP 进行分组配置,不同的 VLAN/广播域 
      分别使用不同的 HSRP 组 进行虚拟网关的配置。
      从而可以实现虚拟网关基于 HSRP 组进行流量的负载均衡。 

    例如:三层交换机作为 VLAN 的网关
          核心交换机 SW1 作为 VLAN 10   和 VLAN 20 的主网关
                         作为 VLAN 30   和 VLAN 40 的辅网关
          核心交换机 SW2 作为 VLAN 30   和 VLAN 40 的主网关
                         作为 VLAN 10   和 VLAN 20 的辅网关                             

          主网关的优先级为 105
          辅网关的优先级为 默认值, 100 ;
          主网关故障以后,备份网关可以升级为主网关
          主网关修复以后,还可以抢占回原有的主网关身份              

          VLAN10的IP地址规划: 
                PC-1: 192.168.10.1 255.255.255.0 
                      192.168.10.254 (虚拟网关IP地址)
                    网关-1: 192.168.10.100 255.255.255.0
                    网关-2: 192.168.10.200 255.255.255.0                      
          VLAN20的IP地址规划: 
                PC-2: 192.168.20.1 255.255.255.0 
                      192.168.20.254 (虚拟网关IP地址)
                    网关-1: 192.168.20.100 255.255.255.0
                    网关-2: 192.168.20.200 255.255.255.0

以上案例配置思路:

1、配置终端设备
      vlan 10 , PC-1 : 192.168.10.1/24 , 192.168.10.254
      vlan 20 , PC-1 : 192.168.20.1/24 , 192.168.20.254       
2、配置网络设备 
     - SW1
         #创建VLAN
         #配置端口模式
         #放入指定的VLAN 或做成 trunk
         #启动路由功能
         #配置网关端口IP地址
         #为网关配置HSRP,将其配置为 VLAN 10 和 VLAN 20  的主根
         #为网关配置HSRP,将其配置为 VLAN 30 和 VLAN 30  的辅根             
     - SW2
         #创建VLAN
         #配置端口模式
         #放入指定的VLAN 或做成 trunk
         #启动路由功能
         #配置网关端口IP地址
         #为网关配置HSRP,将其配置为 VLAN 10 和 VLAN 20  的辅根
         #为网关配置HSRP,将其配置为 VLAN 30 和 VLAN 30  的主根    

     - SW3
         #创建VLAN 
         #配置互联端口(access / trunk )            

3、验证与测试
    SW1/2:
       show vlan brief 
       shwo interface trunk 
       show standby - 查看 HSRP 配置信息
       debug ip icmp
    PC-1/2: 
       ipconfig 
       ping 192.168.x.x 

HSRP-思科私有

 支持多个组;都可以基于组,进行流量的负载均衡。
     HSRP/VRRP ,不可以实现网关的冗余,还可以实现负载均衡。

     100个文件, 10个人 --> 10件/人 (等价的负载均衡)
     100个文件,5个人处理80文件,
                5个人处理20文件,
                            -非等价负载均衡
    唯一表示一个流量的五元组:
        SMAC+DMAC -- SIP+DIP -- TCP/UDP+port
            基于MAC地址负载均衡
                  SMAC 
                  DMAC
            基于IP地址负载均衡
                  SIP
                  DIP 

interface fas0/0
standby 10 ip x.x.x.x

HSRP :
active
standby

在思科设备上实现 VRRP 的配置:

配置:interface fas0/0
vrrp 10 ip x.x.x.x

验证:show vrrp

VRRP-公有标准

华为设备配置
interface gi0/0/0
vrrp vrid 10 virtual-ip 192.168.10.250
验证命令:
display vrrp

-优化
链路跟踪-上行链路跟踪技术
VRRP/HSRP 主网关,可以跟踪上行链路的状态,
如果端口 down ,则会主动降低自己的优先级,
以确保 备网关,可以立刻升为 主网关。
#配置:
interface vlanif 10
vrrp vrid 10 track interface gi0/0/1 reduce 100 ;

                                                                                                                              李军
                                                                                                                                                                                                Tel:15135361516
                                                                                                                                                                                                    qq:344728662
                                                                                                                                                                                    @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com