ijava学习网> 知识分享> Linux> RIPv1 PK RIPv2

RIPv1 PK RIPv2

时间: 2019-02-11 17:02:08 标签RIPv1 , PK , RIPv2

RIPv1 PK RIPv2
1、发送方式不同,1是广播,2是组播;
RIPv2组播,更加安全,因为只有加入了 224.0.0.9这个组
的设备,才可以接收 RIPv2 信息;
因为RIPv1广播时,所有加入该网段的设备,都可以接收
RIP信息,容易造成路由条目的泄露;
2、子网掩码不同,1不支持,2支持;
可以说,RIPv2支持 VLSM;但是V1不支持;

3、认证支持不同,1不支持,2支持(明文+密文)
RIPv2安全性更高一些,因为支持认证;
RIPv1是不支持任何认证功能的;

4、标记支持不同,1不支持,2支持
RIPv2支持标记(tag),从而便于实现大量路由的批量管理;
但是RIPv1不支持;

R1:
router rip
version 2
no auto-summary
network x.x.x.x

x.x.x.x 必须是主类网络的形式;

           # x.x.x.x 表示的是一个网络范围;
              @该命令关注的是本地设备上的直连端口
              @被 x.x.x.x 表示的网络范围覆盖住的IP地址
                所在的端口,启用 RIP 协议进程:
                      %该端口可以发送 RIP 报文;
                      %该端口可以接收 RIP 报文;
                      %该端口的IP地址的中的 网络部分
                        可以放入到 RIP 报文中,传输出去;

例子:
router rip
network 10.0.0.0
network 192.168.12.0

interface loopback 0 --> 10.10.1.1 255.255.255.0
interface fas0/0 --> 192.168.12.1 255.255.255.0


RIP:
1、启用协议
2、配置版本2
3、关闭自动汇总
4、宣告路由并且发送/接收
-宣告方式
network
#仅仅是针对直连;
#必不可少的命令
#该命令可以保证一个物理接口是否可以收发报文;
该命令决定了一个端口是否可以启用RIP协议进程;
redistribute (重分发/重发布)
#可以针对任何类型的路由(只要在路由表中有,就行)
#但是该命令仅仅负责将路由表中的路由装入到RIP
respone 报文中;
R1:
router rip
version 2
no auto-summary
network 192.168.12.0
network 10.0.0.0
!
R2:
router rip
version 2
no auto-summary
network 192.168.12.0
redistribute static /将R2本地路由表中的静态路由,强行拉入
到RIP报文中,以实现传递给R1;
ip route 100.1.1.0 255.255.255.0 192.168.23.2
!
验证命令:
show ip protocols
show ip rotue
show ip route rip

注意:
以后在任何路由协议中,
凡是通过network宣告的路由,都称之为内部路由;
凡是通过 redistribute 宣告的路由,都称之为外部路由;

192.168.1.1 0.0.0.0
192.168.1.5 0.0.0.0

0000 0001
0000 0100
0000 0101
0000 0000
192.168.1.5 192.168.1.1 192.168.1.4 192.168.1.5

0000 0101

0.0.0.5

192.168.1.

                                                                                       李军
                                                                                                                                                     Tel:15135361516
                                                                                                                                                             qq:344728662
                                                                                                                                        @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com