ijava学习网> 知识分享> Linux> RPv2和RPv1的不同点

RPv2和RPv1的不同点

时间: 2019-02-11 17:02:08 标签RPv2 , RPv1 , 不同点

路由的传递方向与数据包的传递方向,永远是相反的。
所以,路由条目中的端口,我们称之为数据包的出端口,
也可以叫路由的入端口;

在路由的传递过程中,是不携带路由属性 - AD ;携带Metric,
并且在发送路由的时候, Metric 会自动的加1;


Metric:度量值,表示的是路由器去往一个条目的距离;
值越小越好;
RIP-hop/跳数
EIGRP-混杂度量值
ISIS-cost/开销
OSPF-cost/开销
BGP- metric

AD:管理距离,表示的是一个路由条目的稳定性;
值越小表示越稳定。取值范围是 0 - 255


RIPv2的报文结构(与V1的不同点)

1、3层不同:是组播 - 224.0.0.9;
2、RIP报文内容不同
-多了一个tag,从而可以实现路由的批量管理
-多了一个掩码,从而可以实现支持 VLSM,从可以实现关闭
自动汇总
-多了一个next-hop,从而可以解决数据转发的次优路径问题
-可以将第一个路由条目,当做认证字段来使用;支持明文和密文
两种加密认证方式

自动汇总 :
-什么协议才有
距离矢量或者是路径矢量路由协议,才具有自动汇总特性
当然,是可以基于网络需求,进行关闭的。
-什么发生
在发送路由的-时候,在主类网络边界,会进行自动汇总
汇总成主类网络的形式,使用的是默认的子网掩码;
-结果
最终,在端口,仅会发送汇总路由,不会发送明细路由;
(汇总本质-发汇总,抑制明细)

RIP中的手动汇总;
-在接口上做,针对的是出向路由;
-在该端口上仅仅发送汇总路由,抑制明细路由的发送;
-RIP中做完手动汇总,需要在本地设备上,手动配置一个
针对该汇总路由的"null0“路由 - 空路由;
为了防止数据转发环路的发生。
配置命令:
interface fas0/0
ip summary-address rip 10.10.0.0 255.255.0.0
!
ip route 10.10.0.0 255.255.0.0 null 0
路由汇总的优点:
1、可以节省发送的路由的条目数,从而可以链路带宽以及对方
设备资源;
2、可以控制不稳定链路对整个网络的影响,增强整个网络的稳定
性。

RIP工作表:
1、数据库 - show ip rip database
2、路由表 - show ip route rip

RIP报文:
1、request
2、respone
RIP路由管理
-路由过滤(distribute-list : 分发列表)
1、匹配路由
#标准ACL-只能匹配路由前缀;不能匹配掩码;
#扩展ACL-可以同时匹配前缀和掩码;(RIP不支持)
2、通过路由过滤工具,调用 ACL ;
router rip
distribute-list {acl} in|out [fas0/0]
3、验证与测试
show ip access-list
show ip protocols
-更改路由属性-AD(ditance)
#将路由的AD调整为 255,也可以实现过滤路由的效果;
ip access-list standard 3 //匹配路由 10.10.3.0
10 permit 10.10.3.0
!
router rip
distance 255 192.168.23.3 0.0.0.0 3
// 将更新源 192.168.23.3 发送的路由,
通过 ACL 进行匹配,匹配成功的,
则进行 AD 值的修改,为 255 。
#正常的修改路由协议的 默认 AD 值:
router rip
distance {value} //更改协议的默认的 AD 值。
#验证命令:
show ip protocols
show ip route
-更改路由属性-Metric(offset-list:偏移列表)

可以将路由的 metric 增大,但是不能减小;

    # 配置命令如下:
            ip access-list standard 4 //匹配感兴趣路由
                10 permit 1 0.10.4.0
            !
            router rip 
                offset-list  {acl}  in/out  {value}  [fas0/0]   
                             // 将特定端口的特定方向的特定路由
                                 的metric 增加特定的 value;                                
    #当我们通过 offset-list 将路由的 metric 调整为 16
     时,该路由则表示不可用 - 即不会出现在路由表中了。     

===============================================================

需求1:
在R2上进行配置;
在发送路由时候,过滤 10.10.2.0/24,确保R3没有,R1有;
需求2:
在R3上进行入向配置;
通过一个ACL条目,同时过滤掉 10.10.1.0/24 和 10.10.2.0/24;

IP  access-list standard 1 
    10  deny 10.10.1.0 0.0.3.0

    通过一个ACL条目,同时匹配多个路由条目时候:
        1、确定多个路由条目的公共前缀;
                相同的位,不变,直接写;
                不同的位,变化,直接写0;
        2、确定公共前缀对应的通配符
                 在通配符中,与前缀中不变的位,对应的写0
                 在通配符中,与前缀中变化的位,对应的写1
例如:
    10.10.1.0
    10.10.2.0
       10.10.0000 00xx.0 --> 上面2个路由的公共部分
        0. 0.0000 0011.0 ---> 与公共前缀对应的通配符;

练习1:
192.168.1.0
192.168.3.0
192.168.5.0
192.168.7.0

通过一个ACL条目,同时匹配以上的4个路由条目:

        0.0.7.0
        0.0.16.0            
    192.168.x.0
            1=0000 0001
            3=0000 0011
            5=0000 0101
            7=0000 0111

             X=0000 0001 =1 
             Y=0000 0110 =6              

    公共前缀:   192.168.1.0   
    通配符  :   0 . 0 .6.0

练习2:
192.168.0.0
192.168.2.0
192.168.4.0
192.168.6.0

通过一个ACL条目,同时匹配以上的4个路由条目:


EIGRP - 思科私有协议

router eigrp 100 //启动 EIGRP 100 的进程;
no auto-summary
network 192.168.12.0 0.0.0.255 // 与 RIP 相比,后面多了
反掩码;

EIGRP工作表:
1、邻居表 - show ip eigrp neighbor
2、数据库 - show ip eigrp topology
3、路由表 - sho ip route eigrp
EIGRP报文:
1、hello :建立EIGRP邻居;
2、update:同步路由更新;
3、ack :实现确认作用,确保报文可靠传输;
4、query :查询报文,用于查询/请求自己丢失的路由信息;
5、reply :回应报文,用于对query报文的回应。


掩码:
在掩码中,1表示精确匹配,0表示随机;
1和0,永远不交叉;
1永远在左边,0永远在右边;
在配置IP地址以及路由的时候,会使用掩码;
反掩码:
在反掩码中,1表示随机,0表示精确匹配;
0和1,永远不交叉;
0永远在左边,1永远在右边;
在路由协议的配置中,通过network命令进行网段宣告时,会使用;
通配符:
在统配符中,1表示随机,0表示精确匹配;
0和1的位置,没有任何的固定限制;
可以连续,可以交叉;
在ACL中,使用的通配符;

                                                                                                                 李军
                                                                                                                                                                                                         Tle:15135361516
                                                                                                                                                                                                                 qq:344728662
                                                                                                                                                                                     @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com