NAT

时间: 2019-02-11 17:02:08 标签nat

NAT

在节省IP地址的情况下,还能够上网:
动态NAT

    -PNAT(port-NAT) / 端口复用

      公有地址:私有地址 = 1:多

实验名称:PNAT的配置与实现
实验拓扑:
实验需求:
确保内网中的所有PC,能与 100.1.1.4 互通。

配置思路:
1、确保路由互通
2、配置NAT网络边界
3、配置感兴趣流量
ip access-list standard aaa
10 permit 192.168.10.0 0.0.0.255
4、创建 NAT 转换条目
ip nat inside source list aaa interface fas0/1
5、验证与测试
show ip access-list
show ip nat translation (verbose) //查看转换表的详细信息
show ip nat statics //查看NAT的统计信息

实验名称:NAT的高级应用 - 端口映射
实验拓扑:
实验需求:
1、确保内网与外网互通(PNAT)
ip nat insdie
ip nat outside
ip access-list aaa permit
ip nat inside source list aaa interface fas0/1
2、确保 R4 的 loopback 0 可以远程访问 PC-1
GW:
ip nat inside source statci tcp 192.168.10.1 23
34.1.1.3 11001
3、验证与测试
show ip nat translation
R4:
telnet 34.1.1.3 11001 /source-interface loopback 0

问题列表(ToDoList)
1\
2\
3\
相信“写下来的力量”

OSI
1 - 信号、0-1、二进制-10进制转换、
2 - MAC、结构、表示 (IP-MAC联动)-ARP (arp\代理ARP\无故ARP)
3 - IP、结构、表示、问题、
空间有限
设备越多
存在浪费
-公有/私有
-子网划分
-IPv6
设备互联
连接 : 网线、光纤
距离 : 中继器和集线器
数量 :冲突域
网桥
交换机
-工作原理
-问题:广播域
-VLAN
#同一个VLAN互通
&成员在相同设备;
&成员在不同设备;
-VLAN同步问题
-Trunk
#不同的VLAN互通(路由)
-网关
-路由器
-多层交换机
&单臂路由
&多臂路由
&SVI
冗余:
传统网络中存在“单点故障”
2层 -备份链路/备份设备
-新问题:环路
-STP/RSTP/MSTP
3层 -备份网关
HSRP/VRRP

链路聚合/捆绑/端口汇聚
PAGP / LACP

ACL (匹配流量)
认识流量
控制流量
认识一下流量:
5元组 -
SIP \ DIP \源端口 \ 目标端口\ 传输层协议

NAT
静态NAT: 公有/私有 = 1/1

动态NAT: 公有/私有 = 1/多

高级应用- 端口映射

 tcp 3389 ---> 远程桌面
 tcp  23  ---> telnet 
 tcp  80  ---> http
 tcp  20/21 --> FTP
 udp  67/68 --> DHCP
 udp  1985  --> HSRP

 IP+传输层协议+端口 = IP套节字(IP socket)

注意:
    1、流量从 inside 去往 outside 时,查看路由表,然后NAT表
    2、流量从 outside 去往 inside 时,查看NAT表,然后路由表      

==========================================================

DHCP : dynamic host configuration protocol
动态 主机 配置 协议

-作用 
  自动的为网络中的客户终端分配IP地址;
  属于OSI模型 第 7  层 。
-角色
   DHCP服务器:包含着大量的可用的IP地址;回应客户端的请求。
       Server
       Router
       Switch
   DHCP客户端:设备加电开机时,就会发送请求,进行IP地址的请求。

-原理
   1、DHCP客户端发送 DHCP  discover ,以广播的方式;
   2、DHCP服务器获得请求之后,确定本地有可用的IP地址,
      则进行回复 DHCP offer ;以广播的方式;
   3、DHCP客户端收到 DHCP offer 以后,会再次发送一个
      DHCP request,为了与服务器进行请求确认。以广播的方式;
   4、DHCP服务器返回一个 DHCP Ack 报文。以广播的方式;

   数据层面:
        L2 + L3 + UDP + DHCP
                  67/68 
                -udp 67 ,表示的是 DHCP 服务器;
                -udp 68 ,表示的是 DHCP 客户端;                 
   ------------------------------------------------------

实验名称:DHCP以及DHCP-relay配置
实验拓扑:
实验需求:
1、DHCP服务器基本实验
#DHCP服务器与客户端在同一个网段;
#确保 VLAN 10 主机获得IP地址,并互通;
2、DHCP中继实验
#DHCP服务器与客户端不在同一个网段;
#确保 VLAN 10 和 VLAN 20 都可以获得IP地址
#确保 VLAN 10 和 VLAN 20 的主机互通;
3、IP地址规划如下:
VLAN 10 - 192.168.10.0/24 ; 192.168.10.254
VLAN 20 - 192.168.20.0/24 ; 192.168.20.254
VLAN 88 - 192.168.88.0/24 ; 192.168.88.254

配置思路:
1、配置 DHCP 客户端;
2、配置 DHCP 服务器 ;
3、配置中间网络设备
-基本实验
#配置交换机
-确保成员主机端口属于同一个网段;
-中继实验
#配置交换机
-划分VLAN,分配端口到指定的VLAN
-配置与 Router 之间的 trunk 链路
#配置路由器
-配置每个VLAN的网关(子接口/单臂路由)
-在每个VLAN的网关下面配置 dhcp-relay ;
#service dhcp // 启动 DHCP 服务;
#interface gi0/0.10
ip helper-address 192.168.88.8
#interface gi0/0.20
ip helper-address 192.168.88.8
-配置连接 VLAN 88 网段的 Server


Router 作为 DHCP 服务器:(如果服务器与客户端不在一个网段)
(依然是需要 DHCP-relay技术的)
1、启动DHCP服务
service dhcp
2、排除不自动分配的DHCP地址
ip dhcp excluded-address 192.168.1.1 192.168.1.10
3、创建DHCP地址池
ip dhcp pool A //创建一个名字为 A 的地址池;
network 192.168.1.0 255.255.255.0 //指定自动分配的网段
default-router 192.168.1.254 //指定分配的网关
dns-server 8.8.8.8 //指定自动分配的 DNS 服务器
4、验证与测试
show ip dhcp binding // 查看分配以后的IP地址


多层交换机作为 DHCP 服务器(与Router的配置方式相同)


配置思路:首先,在路由器上,配置Ip IP ADD 192.168.10.1
在全局模式下,开启dhcp 功能 dhcp enable
在端口上,开启全局功能 dhcp select global
在路由器是 ip pool XXX
network xxx.xxx.xxx.xxx
gatewaylist x.x.x.x

                                                                                                          李军
                                                                                                                                                                                             Tel:15135361516
                                                                                                                                                                                                 qq:344728662
                                                                                                                                                                             @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com