ijava学习网> 知识分享> Linux> HSRP、VRRP、ACL

HSRP、VRRP、ACL

时间: 2019-02-11 17:02:08 标签HSRP , VRRP , ACL

HSRP-思科私有

 支持多个组;都可以基于组,进行流量的负载均衡。
     HSRP/VRRP ,不可以实现网关的冗余,还可以实现负载均衡。

     100个文件, 10个人 --> 10件/人 (等价的负载均衡)
     100个文件,5个人处理80文件,
                5个人处理20文件,
                            -非等价负载均衡
    唯一表示一个流量的五元组:
        SMAC+DMAC -- SIP+DIP -- TCP/UDP+port
            基于MAC地址负载均衡
                  SMAC 
                  DMAC
            基于IP地址负载均衡
                  SIP
                  DIP 

interface fas0/0
standby 10 ip x.x.x.x

HSRP :
active
standby

在思科设备上实现 VRRP 的配置:

配置:interface fas0/0
vrrp 10 ip x.x.x.x

验证:show vrrp

VRRP-公有标准

华为设备配置
interface gi0/0/0
vrrp vrid 10 virtual-ip 192.168.10.250
验证命令:
display vrrp

-优化
链路跟踪-上行链路跟踪技术
VRRP/HSRP 主网关,可以跟踪上行链路的状态,
如果端口 down ,则会主动降低自己的优先级,
以确保 备网关,可以立刻升为 主网关。
#配置:
interface vlanif 10
vrrp vrid 10 track interface gi0/0/1 reduce 100 ;

经过前面的内容学习,我们一个网段互通-交换没问题了;
不同网段的互通-路由没问题了;
在交换和路由网络中的单点故障,也解决了,分别使用的是 STP 和 HSRP/VRRP.

那接下来,我们就看下如何控制“数据流量”:
有些流量可以通,
有些流量不可以通,
通过接下来的“流量控制工具”来实现。

流量控制工具
ACL : access control list , 访问 控制 列表 。
-作用
基于一定的规则,进行数据流量的匹配。
仅仅是用于流量的匹配。
对这些规则的后续处理动作,是由调用ACL的工具来决定的。
-分类
标准ACL:在匹配流量时,只能匹配流量的源IP地址;
扩展ACL:在匹配流量时,可以同时匹配流量的源IP地址、
目标IP地址、TCP/UDP+端口号
-表示
ID:通过数字来表示不同的ACL;
name:通过名字来表示不同的ACL;
-原理
一个ACL,就是一套规则。
一个ACL中,就有多个不同的细分条目;
不同的条目之间,是通过编号进行区分的;
通过ACL匹配流量时,是按照编号从小到大的顺序,依次检查
每个“细分条目”的:
如果能匹配住,则执行前面的动作(deny/permit);
如果不能,则继续检查下一个“细分条目”
如果到最后都没有匹配住,则执行 ACL 最后一个
默认的“细分条目” --- 拒绝所有(deny any )!
注意:
任何一种类型的ACL,最后都有一个“拒绝所有”的条目。
-配置步骤:
#定义ACL
R4:
ip acces-list standard deny-ping
10 deny 192.168.12.0 0.0.0.255
20 permit any
#调用ACL
R4:
interface fas0/1
ip access-group deny-ping in
#验证ACL
R4;
show ip access-list
#流量测试
在所有设备上: ping 10.10.4.4 ,
R1无法通 , 其他都通。

注意: 
    标准ACL匹配流量时,不够精确,所以我们强烈建议:
      将标准ACL调用在距离“目标”特别近的地方。

R1:
ip route 10.10.4.0 255.255.255.0 192.168.12.2
ip route 192.168.23.0 255.255.255.0 192.168.12.2
ip route 192.168.34.0 255.255.255.0 192.168.12.2

R2:
ip route 10.10.1.0 255.255.255.0 192.168.12.1
ip route 10.10.4.0 255.255.255.0 192.168.23.2
ip route 192.168.34.0 255.255.255.0 192.168.23.2

R3:
ip route 10.10.1.0 255.255.255.0 192.168.23.2
ip route 10.10.4.0 255.255.255.0 192.168.34.4
ip route 192.168.12.0 255.255.255.0 192.168.23.2

R4:
ip route 0.0.0.0 0.0.0.0 192.168.34.3
// 该路由表示的是“默认路由”,代表所有网段。

                                                                                                               李军
                                                                                                                                                                                                         Tel:15135361516
                                                                                                                                                                                                         qq:344728662
                                                                                                                                                                                 @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com