ijava学习网> 知识分享> Linux> DHCP、UDP、华为ACL

DHCP、UDP、华为ACL

时间: 2019-02-11 17:02:08 标签DHCP , UDP , 华为
             IoT

DHCP
server
router
switch
-2层交换机
-多层交换机

DHCP配置思路:
1、开启 DHCP 服务
service dhcp
2、创建 DHCP 地址池
ip-address
mask
gateway
dns (domain name server )
www.baidu.com -----> ip
3、配置DHCP-relay(可选)
4、验证与测试

  ACL\NAT\DHCP --> 华为

=============================================================
DHCP实验

实验名称
实验拓扑
实验需求
1、PC-1/2 属于不同的 VLAN ;
2、DHCP-Server 属于 VLAN 10 ,为PC-1/2分配IP地址
3、确保 PC-1/2 互通
4、PC-1/2网关在多层交换机;
5、地址规划:
VLAN10:192.168.10.0/24 192.168.10.254
VLAN20:192.168.20.0/24 192.168.20.254

实验步骤:
第一种类型的配置思路:(OSI:1/2/3/7)
1、确保设备物理互联正确;
2、确保交换网络正常
vlan/trunk/access
3、确保路由网络正常
ip/gateway/routing
4、DHCP相关配置
-DHCP服务器
#需中继
#不需要
-DHCP客户端

第二种类型的配置思路:(基于设备功能角色)
1、配置终端设备
-各种PC
2、配置网络设备
-配置交换机
-配置路由器
-配置防火墙
3、配置服务器设备
-各种功能的服务器(此处为DHCP)

##############################################################
Router 作为 DHCP 服务器:(如果服务器与客户端不在一个网段)
(依然是需要 DHCP-relay技术的)
1、启动DHCP服务
service dhcp
2、排除不自动分配的DHCP地址
ip dhcp excluded-address 192.168.1.1 192.168.1.10
3、创建DHCP地址池
ip dhcp pool A //创建一个名字为 A 的地址池;
network 192.168.1.0 255.255.255.0 //指定自动分配的网段
default-router 192.168.1.254 //指定分配的网关
dns-server 8.8.8.8 //指定自动分配的 DNS 服务器
4、验证与测试
show ip dhcp binding // 查看分配以后的IP地址

多层交换机作为 DHCP 服务器(与Router的配置方式相同)

!
no ip dhcp excluded-address 192.168.1.1
no ip dhcp excluded-address 192.168.1.3
no ip dhcp excluded-address 192.168.1.5
no ip dhcp excluded-address 192.168.1.7
no ip dhcp excluded-address 192.168.2.1 192.168.2.5

IP头部(20Byte)

TCP:transmission control protocol - 传输控制协议(20Byte)
transport
TCP连接稳定、可靠,可以在长时间内实现大量报文的可靠、高效传输;
1、报文是有序列号(sequence number)
2、有确认机制(ack)
3、有窗口机制(windows-滑动窗口)

缺点:
-建立时间长

UDP:user datagram protocol - 用户 数据报文 协议 (8 Byte)
1、传输速度快

缺点:
-不稳定、不安全、不可靠

华为的ACL
3层ACL - 面向的是IP数据包;
2层ACL - 面向的是2层数据包;关注的是 MAC地址+vlan+ Type

IP-ACL (3层ACL)
基本ACL - basic acl -----> 标准ACL
高级ACL - advanced acl ----> 扩展ACL

对本地设备发起的流量,不起作用。

表示:
ID
2000- 2999 , 基本ACL
3000- 3999 , 高级ACL
name
acl abc basic/advance

配置步骤:
1、创建ACL
[R1]acl 2000
[R1-acl-basic-2000]rule deny source x.x.x.x y.y.y.y
上面是标准,下面是扩展的;
[R1]acl 3000
[R1-acl-basic-2000]rule deny {protocol} source x.x.x.x [source-wildcard] [source-port]
destination x.x.x.x [destination-wildcard][destination-port ]

2、调用ACL
interface gi0/0/0
traffic-filter inbound/outbound acl {id/name}

3、验证ACL
display acl all

     CCNP SWITCH 300-115 交换机
     CCNP ROUTE  300-101 路由器

华为的ACL:
对本地设备发起的流量,不起作用。
ACL最后一个隐含的条目,表示允许所有
在ACL中,源IP、目标IP、源端口、目标端口,
任何一个元素不写,表示的都是 any ;

如果想在 ACL 中写一个拒绝/允许所有,可以直接写:
        rule  deny 
            OR 
        rule  permit 

AR1:
dhcp enable // 开启 DHCP 服务;

interface gi0/0/0
ip address 192.168.10.254 255.255.255.0 ;
dhcp relay server-ip 192.168.13.3 //写的是 DHCP 服务器地址
类似于 helper-address
interface gi0/0/1 --> 连接 AR2
ip address 192.168.12.1 255.255.255.0
interface gi0/0/2 --> 连接 AR3(DHCP服务器)
ip address 192.168.13.1 255.255.255.0

AR2:
dhcp enable //开启DHCP服务

 interface gi0/0/0 --> 连接 VLAN 20 客户端的/VLAN20网关;
     ip address 192.168.20.254 255.255.255.0
     dhcp relay server-ip 192.168.13.3 //DHCP服务器的地址  
 interface gi0/0/1 -->连接 AR1 
     ip address 192.168.12.2 255.255.255.0
  !
  ip route-static 192.168.13.0  255.255.255.0 192.168.12.1
      -->配置一个去往 DHCP 服务器所在网段的路由;

AR3:(DHCP-server)
dhcp enable //开启DHCP服务;
interface gi0/0/0 --->连接的是 AR1
ip address 192.168.13.3 255.255.255.0
dhcp select global // 当设备在该端口上收到DHCP discover
报文时,去查找 DHCP 的全局地址池
基于网关IP地址,找到对应的DHCP地址池,
分配可以使用的IP地址;
ip route-static 192.168.10.0 255.255.255.0 192.168.13.1
ip route-static 192.168.20.0 255.255.255.0 192.168.13.1

                                                                                                            李军
                                                                                                                                                                                                 Tel:15135361516
                                                                                                                                                                                                         qq:344728662
                                                                                                                                                                                     @:501xiaofeng@163.com

版权说明| 关于ijava| 合作伙伴| 联系我们| 网站地图| 招贤纳士

Copyright © 2017 www.ijava.com All Rights Reserved 版权所有•ijava学习网 京ICP备14061482号-18         官方QQ:3325669927

ijava学习网提供免费java教程和大量java面试题库,给高级会员提供免费的java培训,同时提共一些java开发项目和java下载,java工程师,java菜鸟们快来哦。记住我们的网站:www.ijava.com